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1 概要 

Mascot Daemon は Mascot 検索プロセスの自動化を支援する、Mascot Server のクライアントソフトウエアです。次の動作     

モードをサポートしています。 

(1) バッチ・モード（Batch） 

複数の質量データファイルに対して逐一 Mascot 検索を実行します。検索開始日時を指定することもできます。 

(2) リアルタイムモニター・モード（Real-time monitor） 

指定したフォルダ(ローカルあるいはネットワーク上)を監視し、そのフォルダ内に新たに作成された質量データファイル

を取得して、Mascot検索を実行します。 

(3) フォローアップ・モード（Follow-up） 

検索結果のスコアあるいは期待値が、あらかじめ指定したそれらの数値に達しなかった場合、別の検索条件を使って自動

的に再検索を実行します。定期的に更新される配列データベースに対して自動的に再検索を実行させることもできます。 

1.1 タスク 

Mascot Daemon は検索を「タスク」単位で管理します。タスクは次の６つの情報で構成されています。 

(1) タスク名 

(2) 検索条件 (検索条件ファイル「*.par」ファイルとして前もって作成) 

(3) 質量データファイル (生の質量データファイルの場合はフィルタプログラムを指定) 

(4) 検索の実行時期 

(5) 再検索条件 (Follow-up の条件) 

(6) 外部プログラムの起動 (検索結果の Auto-export 機能、External processes機能のサポート) 

タスクは４つの状態（実行中：Running、中断：Paused、完了：Completed、キャンセル：Canceled）をとることができます。

Paused タスクは再実行（Resume）することができます。Paused タスクと Completed タスクはキャンセルまたは削除することが

できます。 

1.2 フィルタプログラム（Data Import Filters） 

Mascot Daemon はテキスト形式のピークリストファイルおよび生の質量データファイルをサポートしています。テキスト形式

のピークリストファイル（たとえば MGF ファイル）は特別な処理をせずにそのまま Mascot Server に投入することができます

が、生の質量データファイルについては、対応するフィルタプログラムを利用してピーク抽出処理を行い、Mascot Server に   

投入できるピークリストファイル（たとえば MGF ファイル）を作成する必要があります。Mascot Daemon は Mascot Distiller 

および Windowsのコマンドラインで実行できるフィルタプログラムをサポートしています。 

(1) Mascot Distiller：http://www.matrixscience.com/distiller.html 

全ての質量分析計ベンダーの生の質量データファイルを処理することができます。別途ライセンスが必要です。 

(2) Thermo ExtractMSn 

Thermo Fisher Scientific 社が提供する Xcalibur RAWファイル処理プログラムです。すでにプログラムの開発・保守は

終了していますので、Q-Exactiveなどで使われている新しいバージョンの Xcalibur が出力する RAWファイルには対応して

いません。 
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(3) AB Sciex MS Data Converter：http://www.absciex.com/software-downloads-x2110 

AB Sciex 社が提供するプログラムです。Wiff ファイルおよび TOF/TOF データファイルを処理することができます。 

(4) ProteoWizard MSConvert：http://proteowizard.sourceforge.net/downloads.shtml 

さまざまな質量データフォーマットに対応しています（http://proteowizard.sourceforge.net/doc_users.html の

Supported format をご覧ください）。 

(5) フィルタプログラムの追加 

Windows のコマンドラインから実行できるプログラムであれば Mascot Daemon の[Data import filer]リストに追加する

ことができます。詳しくは Mascot Daemon のヘルプページの「Adding a new data import filter」項をご覧ください。 

1.3 運用形態 

ひとつの Mascot Server に対し、複数の Mascot Daemon を利用することができます。たとえば、複数の質量分析計をお持ちの

場合、それぞれの質量分析計のために用意した PCに Mascot Daemon をインストールすることもできますし、研究者が所有する

PC に Mascot Daemon をインストールし、研究所内にある、種類が異なる質量分析計や複数の質量分析計から出力される質量    

データファイルを一元的に処理することもできます。 

1.4 他のプログラムとの連携 

External processes機能を使うことにより、タスク開始前後および Mascot検索実行前後のタイミングで外部のプログラムを

実行することができます。 
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2 インストレーションと環境設定 

2.1 動作環境 
Mascot Daemon は、 

・32bit および 64bitの Windows Daemon SP3 あるいは Server 2003 SP2 以上 

・Microsoft .NET framework 4.0以上 

・Microsoft Internet Explorerが正しく動作している (古いコンピュータのみ。Win10 最新版では必須ではない) 

の動作環境を持った PC にインストールすることができます。Mascot Daemonは HTTP プロトコルを利用して Mascot Serverと

通信しますが、弊社がインターネット上で公開している Mascot Server（http://www.matrixscience.com/cgi/）とは通信できま

せんのでご注意ください。 

2.2 新規インストレーション 

Mascot Daemonをインストールする前に、Mascot Serverが正しく動作していることを確認してください。また、Mascot Server

と同じバージョンの Mascot Daemon をインストールしてください。インストール作業は数分で終了します。 

(1) Mascot Daemonをインストールしたい PCの Webブラウザから Mascot 検索を実行し、Mascot Server が正しく動作する事

を確認してください。もし Mascot Server が正しく動作しない場合は、この問題を解決した後に、Mascot Daemon を   

インストールしてください。 

(2) Web ブラウザを起動し、Mascot Server の「Welcome」トップページ「http://ホスト名/mascot/」にアクセスしてくださ

い。 

(3) 「Welcome」トップページの中程にある「Mascot Daemon」項の[Install]リンクをクリックしてください。「Installing 

Mascot Daemon」ページが表示されます 

(4) 項目「3.」の[setup]リンクをクリックすると Mascot Daemon のインス

ト ー ラ で あ る 「 daemon_setup.exe 」 が 「 C:\Users\ ユ ー ザ 名

\Downloads」フォルダにダウンロードされます。それを実行すると、

Windows が 32bit か 64bit かを自動的認識し、右図のような「Setup 

Wizard」が起動しますので、表示されるダイアログの内容に従って 

インストレーションを進めてください。なお、Microsoft .NET 

framework がインストールされていない場合はその旨のメッセージ

が表示されますので、次に示すリンクからダウンロードしてインス

トールし、再度「daemon_setup.exe」を実行してください。 

 

▶ Microsoft .NET framework 4.6： 

https://www.microsoft.com/en-gb/download/details.aspx?id=48130 

 

(5) 使用許諾契約書をお読みいただき、同意の上「I accept the agreement」にチェックを入れて「Next」に進んでください。 

z 
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(6) Mascot Daemon をどのフォルダにインストールするか設定して 

ください。 

 

 

 

 

 

(7) デスクトップ上に Mascot Daemonのショートカットを設置するか 

どうか選択してください。 

 

 

 

 

 

 

(8) インストール前に設定の確認が入ります。 

問題なければ「Install」に進んでください。 

 

 

 

 

 

 

 

(5) インストールが終了し、[Launch Mascot Daemon]にチェックが入っ

た状態で[Finish]ボタンを押すと、Mascot Daemon は自動的に起

動し、右図に示す[Preferences]ダイアログの[Intranet]タブが表

示されます。自動的に起動しない場合は、[スタート]→ [Mascot 

Daemon]を選択し、Mascot Daemon を起動してください。[Mascot 

Server URL, up to and including cgi directory]入力欄に

Mascot Serverの URL（http://ホスト名/mascot/cgi/）を入力し、

[Save]ボタンを押してください。Mascot Server との接続が確立

されると Mascot Daemon の再起動を促されますので、Mascot 

Daemonを再起動してください。 
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(6) Mascot Daemonを再起動すると、右図に示すウインドウが表示され

ます。これで Mascot Daemonのインストール作業は終了です 

 

 

 

 

2.3 バージョンアップ 

Mascot Daemonと Mascot Serverは対になって動作しますので、互いに同じバージョンであることが必要です。Mascot Server

をアップグレードして正しく動作することを確認した後に、Mascot Daemon のアップグレード作業を行ってください。 

(1) 既存の Mascot Daemon が格納されている「C:\Program Files\Matrix Science\Mascot Daemon」フォルダをバックアップ

してください。 

(2) Windows の[スタート]→[コントロールパネル]→[プログラム]→[プログラムと機能]から既存の Mascot Daemon をアン

インストールしてください。 

(3) \Web ブラウザを起動し、Mascot Server の「Welcome」

トップページ「http://ホスト名/mascot/」にアクセス

し、ページの中程にある「Mascot Daemon」項の

「 Upgrade」リンクをクリックしてください。

「Upgrading Mascot Daemon」ページが表示されます。 

(4) 項目「2.」の setup リンクをクリックすると Mascot Daemon のインストーラである「daemon_setup.exe」が「C:\Users\ユ

ーザ名\Downloads」フォルダにダウンロードされます。それを実行すると、Windowsが 32bit か 64bit かを自動的認識

し、右図のような「Setup Wizard」が起動しますので、表示され

るダイアログの内容に従ってインストレーションを進めてくだ

さい。なお、Microsoft .NET framework がインストールされて

いない場合はその旨のメッセージが表示されますので、次に示す

どちらかのリンクからダウンロードしてインストールし、再度

「daemon_setup.exe」を実行してください。 

▶ Microsoft .NET framework 4.6： 

https://www.microsoft.com/en-

gb/download/details.aspx?id=48130 

 

(5) インストールが終了して[Finish]ボタンを押すと、Mascot Daemon

は自動的に起動し、右図に示す[Preferences]ダイアログの

[Intranet]タブが表示されます。自動的に起動しない場合は、[ス

タート]→ [Mascot Daemon]を選択し、Mascot Daemon を起動して

ください。[Mascot Server URL, up to and including directory]

入力欄に Mascot Serverの URL（http://ホスト名/mascot/cgi/）

を入力し、[Save]ボタンを押してください。Mascot Server との接

続が確立されると Mascot Daemon の再起動を促されますので、

Mascot Daemon を再起動してください。 
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(6) Mascot Daemon を再起動すると、右図に示すウインドウが表示されます。 

これで Mascot Daemonのインストール作業は終了です 

 

 

 

 

 

 

 

2.4 変換プログラム :ProteoWizard のインストール方法 

Mascot Daemon がインストールされている PCに ProteoWizard msConvert がインストールされていると、様々なフォーマット

の質量データファイルを処理することができます。 

(1) Webブラウザを起動して、 

「 http://proteowizard.sourceforge.net/download.html」  に 

アクセスし、お客さまの環境にあった Platform の ProteoWizard

をダウンロードし、実行してください。 

 

 

 

 

 

 

 

(2) [Install for all users of this machine]を選び、[Next]を

押してください。 

 

 

 

 

 

 

 

 

 

(3) インストール先のフォルダを指定し、[Next]を押してくださ

い。 

 

 

 

 

 

 

 

 

http://proteowizard.sourceforge.net/download.html
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(4) ファイルを右クリックしたときに ProteoWizard と関連付け

るかの設定が出ます。必要に応じて選択し、[Next]を押して

ください。 

 

 

 

 

 

 

 

 

 

(5) [Install]を押してインストールを実行してください。完了し

たら[Finish]を押してください。 

 

 

 

 

 

 

 

 

 

 

 

 

 

(6) Mascot Daemonのメニューバー[Edit]→[Preferences]から[Data import filters]を選択し、[Full path to ProteoWizard 

msConvert]の項目に、インストールした ProteoWizard の msConvert.exe のフォルダパスを入力してください。[Browse]

で選択することもできます。入力したら[Save]ボタンを押してください。Mascot Daemon の再起動を促されますので、

Mascot Daemon を再起動してください。 
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2.5 ライセンスの使用許諾 

Mascot Daemon は Mascot Server にバンドルされたソフトウエアです。Mascot Server ライセンスをお持ちのお客様は、    

お客様が所有している任意の PCに Mascot Daemon をインストールすることができます。 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

2.6 アンインストール 

(1) [スタート]→[コントロールパネル]→[プログラム]→[プログラムと機能]を選択してください。現在インストールされて

いるプログラムがリスト表示されます。 

(2)リストから[Mascot Daemon version 2.7.*]を選択して右クリックし、[アンインストール]を選択してください。 
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3 チュートリアル 

Mascot Daemonを利用した Mascot検索の流れは、Web ブラウザを利用した Mascot 検索の流れと基本的に同じです。すなわち、 

(1) 検索条件を設定し、 

(2) 質量データファイルを指定して Mascot 検索を実行し、 

(3) 必要に応じて Mascot検索の進捗状況を確認し、 

(4) 検索終了後に検索結果を閲覧する。 

という流れになります。ここでは、「C:\ProgramData\Matrix Science\Mascot Daemon\data」フォルダにある MS/MSの質量デ

ータファイルを使って Mascot Daemonの使い方を説明していきます。 

3.1 Mascot Daemonの起動 

[スタート]→[Mascot Daemon]を選択してください。ス

タートアップ画面が表示された後に Mascot Daemonが起動

し、図 3-1 に示すウインドウが表示されます。Mascot 

Daemon のウインドウは４つのタブ([Parameter Editor]、

[Task Editor]、[Event Log]、[Status])と３つのメニュー

([File]、[Edit]、[Help])から構成されています。 

 

 

 

 

 

3.2 検索条件ファイルの作成 

一番右にある[Parameter Editor]タブをクリックしてく

ださい。図 3-2 のように、Web ブラウザに表示される検索条

件設定画面と同じような画面に切り替わります。ここで検

索条件を設定し、検索条件ファイル(拡張子「.par」を持っ

たテキストファイル)として保存します。 

図 3-2を参照しながら検索条件として次の内容を設定し、

[Save As …]ボタンを使って、「tour1.par」というファイ

ル名で保存してください。 

[Database] →「SwissProt」を選択 

[Enzyme] →「Trypsin」を選択 

[Peptide tol. ±] →「0.1」を入力、「Da」を選択 

[Data format] →「Micromass (.PKL)」を選択 

[MS/MS tol. ±] →「0.3」を入力、「Da」を選択 

[Instrument] →「ESI-QUAD-TOF」を選択 

なお、Mascot Daemon を起動すると、デフォルトの検索条件として default.par ファイルが読み込まれると同時に、

[Preferences]ダイアログの[Intranet]タブで指定された Mascot Server に接続します。 

図 3-2 [Parameter Editor]タブ：検索条件の設定 

図 3-1 Mascot Daemonの起動画面 
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3.3 タスクの作成と実行 

Mascot Daemonでは、検索の単位をタスクとして定義します。タ

スクは次の６つの項目で構成されています。(1)～(4)は必須設定

項目、(5)および(6)はオプション設定項目です。 

(1) タスク名 

(2) 検索条件 (「*.par」ファイルとして作成) 

(3) 質量データファイル（生の質量データファイルの場合はそ

れに対応するフィルタプログラム） 

(4) 検索の実行時期 

(5) 再検索条件 (Follow-up の条件) 

(6) 外部プログラムの起動 

ここでは、「3.2 検索条件ファイルの作成」で作成した検索条

件ファイル「tour1.par」と、質量データファイル

「C:\ProgramData\Matrix Science\Mascot 

Daemon\data\01260005.pkl」を使って「Simple test search」タ

スクを作成し、実行します。右から２番目の[Task Editor]タブ

をクリックし、図 3-3を参照しながら、次の内容を持つタスクを

定義してください。 

① [Task] → タスク名として「Simple test search」を入

力 

② [Parameter set] → [...]ボタンから「tour1.par」を読

込む 

③ [Data file list] → [Add Files]ボタンから質量データ

ファイル「01260005.pkl」を読込む 

[Run]ボタンを押してタスクを実行すると、図 3-4に示す[Status]タブに切り替わります。実行されたタスクが新しいタス

クとして認識されるまではタスク名の前に砂時計が表示されます。検索が開始されると時計マークが表示され、

Status 欄には running が表示されます。 

 

3.4 検索結果の表示 
検索が終了すると、図 3-4 の[Status]タブの内容は図 3-5 の 

ようになります。タスク名の前には検索が終了したことを示す 

緑のチェックマーク(✓)が表示されます。チェックマーク左の  

＋ マーク（タスクノードと呼びます）をクリックすると、フォル

ダアイコンとデータファイル名[01260005.pkl]が表示されます。

[01260005.pkl]をクリックすると、右側ウインドウに検索結果の

概要が表示されます。閾値スコアよりも大きなスコアを持つ複数

のタンパク質がヒットした場合は、最もスコアが高いタンパク質

の情報とプロテインスコアが表示されます。閾値を超える    

タ ンパク質 がヒット しなかっ た場合は [Accession]欄に    

<no result>と表示されます。 

[Result file URL]欄に表示されている URLは Mascot Server 上

に保存された検索結果ファイルが指定されており、そこをクリッ

図 3-3 タスクの作成と実行 

図 3-4 [Status]タブと検索中を示す時計マークのタスク 

図 3-5 [Status]タブと検索結果の概要表示 
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クすると Web ブラウザが起動し、対応する検索結果ページが表

示されます。なお、[Data import filter]として Mascot 

Distiller を利用した場合は、 [Result file URL]欄の下に

[Mascot Distiller]欄が追加され、Mascot Distiller のプロ

ジェクトファイル名が表示されます。そこをクリックすると

Mascot Distiller が起動し、ピーク抽出処理等の処理結果が

表示されます。 

[Status]タブの中では、タスクの状態を示すために、図 3-6

に示すアイコンが使われます。 

リアルタイムモニター・モードでは、常に新しい質量データ

ファイルを待ち受ける（アイドリング）状態にありますので、タスクは完結せず、常に砂時計アイコンが表示されます。 

動作中のタスクは中断させることができます。また、完結したタスクと中断したタスクは削除することができます。タスク名

をクリックして選択すると[Status]タブ下方にあるボタンがアクティブになりますので、処理したい内容に対応するボタン

（[Pause]、[Resume]、[Clone]、[Cancel]、[Delete]）を押してください。[Clone]ボタンを押すと、そのタスクが「Copy of タ

スク名」として複製され、[Task Editor]タブに表示されます。[Status]タブの[Delete]ボタンを使ってタスクを削除しても、

それに対応する Mascot Server 上の検索結果ファイル（C:\inetpub\mascot\data\yyyymmdd\Fxxxxxx.dat）は削除されません。

Mascot Daemon の Task databaseファイル（C:\ProgramData\Matrix Science\Mascot Daemon\taskdb.vdb5）からそのタスクと

関連情報エントリが削除されるだけです。検索結果は Mascot Server 上に残り、Mascot search logページからいつでも参照す

ることができます。なお、タスク名を右クリックしても上記と同じ内容の操作を行うことができます。 

[Event Log]タブには、タスクの進捗状況やエラーメッセージなどが表示されます。このログは「C:\ProgramData\Matrix 

Science\Mascot Daemon\Mascot_Daemon_Event_Log.csv」ファイルに記録されています。 

3.5 フォローアップ・モード 

例えば、 

「トリプシンで消化した試料から得られた MS/MSの質量データ

を Human由来のタンパク質に対して検索を行い、有意なヒッ

トが得られなかった（スコアが閾値よりも小さいあるいは期

待値が 0.05よりも大きい）時は、すべての切断特性をもった

消化酵素である[None]を使って再検索を実行する」 

というような、再検索を伴う条件付き検索を行いたい場合は、

フォローアップ・モードが有効です。 

最初に２つの検索条件を定義します。ひとつは通常のタスク用、

もうひとつはフォローアップ・タスク用です。[Parameter Editor]

タブを開き、通常のタスク用として、図 3-7 に示すような検索条

件（[Enzyme]は「Trypsin」、[Data format]は「Sequest(.DTA)」な

ど）を設定し、[Save As]ボタンで「tour2.par」として保存してく

ださい。同様に、フォローアップ・タスク用として、図 3-7 の 

[Enzyme]を(「Trypsin」から)「None」にして、[Save As]ボタンで

「tour3.par」として保存してください。 

次に、フォローアップ・タスクを定義・実行した後、通常のタス

クを定義・実行します。[Task Editor]タブを開き、まず最初に、

図 3-8 のようにフォローアップ・タスクを定義します。[Task]で

「No enzyme follower」を入力し、[Parameter set]の[...]ボタ

ンから「tour3.par」ファイルを読み込み、[Schedule]フレームの

[Follow-up]を選択した後、[Run]ボタンを押して「No enzyme 

図 3-6 タスクの状態を示すアイコンの意味 

時計アイコン：動作中(検索中)のタスク 

鎖アイコン：Follow-upタスク 

砂時計アイコン：タスクの中断処理中 

チェックアイコン：完結したタスク 

バッテンアイコン：キャンセルされたタスク 

中断アイコン：中断したタスク 

図 3-7 tour2.par の検索条件 

図 3-8 フォローアップ・タスクの定義と実行 
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follower」タスクを実行してください。自動的に[Status]タブに切り替わりますので、左側ウインドウのツリーに「No enzyme 

follower」のフォローアップ・タスクが追加されていることを確認

してください。タスク名の左側にはこのタスクがフォローアップ・

タスクであることを示す鎖アイコンが表示されます。 

[Task Editor]タブに戻り、図 3-9のように「Trypsin first pass 

search」タスクを定義してください。検索条件ファイルとして

「 tour2.par」を、質量データファイルとして「 C:\Program 

Files\Matrix Science\Mascot Daemon\data」フォルダにある２つ

の DTA ファイルを読み込んでください。 

 LCQ_Digest03.0486.0492.2.dta 

 LCQ_Digest03.0921.0924.2.dta 

フォローアップの条件は、「If probability that match is 

random > 1 in」を選択し、期待値が 0.05（1/20）になるように

「20」を入力してください。[Pass data to]はすでに実行して待

機状態になっている「No enzyme follower」タスクを選択してく

ださい。 

[Run]ボタンを押して「Trypsin first pass search」タスクを

実行すると、まず「tour2.par」の検索条件で検索が実行され、期

待値が 0.05よりも大きい(スコアが閾値よりも小さい)、有意では

ない検索結果が得られた場合は、その質量データファイルはアイ

ドリング状態で待機している「No enzyme follower」タスクに渡

され、「tour3.par」の検索条件で再検索されます。検索が終了する

と、[Status]タブにはこれらの検索結果が図 3-10 のようなツリー

構造で表示されます(タスク番号が 2 と 3)。 

「LCQ_Digest03.0486.0492.2.dta」に対する検索に関しては期

待値が 0.05よりも小さい有意なタンパク質がヒットしているた

め、「No enzyme follower」タスクを利用した再検索は実行され

なかったのに対し、「LCQ_Digest03.0921.0924.2.dta」に対する

検索に関しては 0.05 よりも大きな値が得られたため、「No 

enzyme follower」タスクを使用して再検索が実行されていま

す。この検索結果から、「LCQ_Digest03.0921.0924.2.dta」デー

タファイルに対応するペプチドはトリプシン消化によって得られ

たペプチド（Tryptic peptide）ではなかったことがわかります

(検索結果は図 3-11 のようになります)。 

このように、フォローアップ・モードは、同じ質量データファ

イルに対して異なる検索条件で再検索したい場合に威力を発揮し

ます。なお、[Status]タブの「LCQ_Digest03.0921.0924.2.dta」

アイコンを「No Enzyme follower」タスクのアイコンにドラッグ

＆ドロップすることにより、「No Enzyme follower」タスクを実

行することもできます。 

Mascot Daemon では様々なタイプのフォローアップ・タスクを

定義することができます。たとえば、UniProt 配列データベース

に対して検索を実行して有意にヒットしなかった質量データファイルについて、後日更新された UniProt配列データベースに

対して、指定した時間間隔(分、時、日、週、月)で再検索するためのフォローアップ・タスクを定義することもできます。 

 

 

図 3-10 フォローアップ・タスクの実行結果 

図 3-9 通常のタスクの定義と実行 

図 3-11 フォローアップ・タスクの検索結果ページ 
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4 リファレンス 

4.1 メニュー 

(1) [File]メニュー 

次の[Exit]以外のコマンドは[Parameter Editor]タブを開いて

いるときに有効です。また、[Parameter Editor]タブにも同じ機

能のボタンが配置されています。 

[New …] 

検索条件の設定をデフォルトに戻します。 

[Open …] 

検索条件ファイルの読み込みダイアログを表示します。 

[Save] 

読み込まれている検索条件ファイルに現在の検索条件を上書き保存します。 

[Save As …] 

検索条件ファイル名を指定して現在の検索条件を保存します。 

[Exit] 

Mascot Daemon GUIを終了します。この操作では Mascot Daemon Engine プログラムは停止しません。Mascot Daemon Engine

プログラムを終了したい場合は、Windows のタスクトレーにある歯車アイコンを右クリックして[Exit]を選択してください。 

(2) [Edit]メニュー 

[Cut]から[Clear]までのコマンドは[Parameter Editor]タブあるいは[Task Editor]タブを開いているときに有効です。 

[Cut] 

選択したテキストをクリップボードにコピーした後に削除します。 

[Copy] 

選択したテキストをクリップボードにコピーします。 

[Paste] 

クリップボードのテキストをカーソル位置に挿入します。または選択したテキストを置き換えます。 

[Clear] 

選択したテキストを削除します。 

[Preferences] 

[Preferences]ダイアログを表示します。 

[ODBC Information …] 

現在使用しているタスク・データベース ODBC connection の詳細を示すダイアログを表示します。 

[Refresh] 

[Status]タブの表示内容を更新します。 

(3) [Help]メニュー 

[Mascot Daemon Help …] 

オンラインヘルプを表示します。 

[Register Mascot Distiller] 

Mascot Distiller の Mascot Daemon 接続モジュール・ライセンスを登録する際に使用します。登録には弊社が発行したシ

図 4-1 メニュー 
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リアル番号が必要になります。 

[About …] 

Mascot Daemon のバージョンをチェックすることができます。 

4.2 [Preferences]ダイアログ 

[Preferences]ダイアログの中で使われる値はグローバルな設定値として Windows OS のレジストリに保存されるため、値を 

変更した場合は Mascot Daemon（GUI および Engine）を再起動する必要があります。 

(1) [Intranet]タブ 

Mascot Daemon と接続する Mascot Server の URL を入力してく

ださい。指定した Mascot Server に接続できない場合は warning

メッセージが表示されます。なお、弊社がインターネット上で公開

している Mascot Server の URL は使えません。 

Web サーバがユーザ名とパスワードを要求する設定になってい

る場合は、これらの情報を[Authentication]タブの[Web Server 

Authentication]欄に入力してください。 

Mascot Daemon と Mascot Serverを接続するための４つの HTTP

関連の設定値は、通常デフォルト値で問題ありません。[HTTP 

access type]として[Proxy server]を選択した場合は[HTTP proxy 

server]欄に HTTP プロキシサーバの URL を入力してください。

[HTTP timeout(seconds)]の値は、設定ファイルなどの小さなファ

イルを転送する際に使われます。大きなサイズの質量データファイルのアップロードや検索結果レポートのダウンロードに対す

る timeout 設定は Mascot Daemon のプログラム内に書き込まれています。 

Mascot Daemonと Mascot Server間に認証が必要な Proxy serverが存在する場合は「HTTP/1.0」を選択してください。 

(2) [Data import filters]タブ 

[Root folder for files cached by data import filters]入力

欄にはタスクに関係するファイル（ピークリストファイル、Mascot 

Distillerのプロジェクトファイル、検索結果の CSV出力ファイル

など）を格納するフォルダパスを指定してください。 

「Thermo ExtractMSn」、「AB SCIEX MS Data Converter」、

「ProteoWizard msConvert」の３つのフィルタプログラムを標準

でサポートしていますので、これらのフィルタプログラムをイン

ストールした後に、それぞれの入力欄に実行プログラムのファイ

ルパスを指定してください。[Task Editor]の[Data import 

filter]ドロップダウンメニューにそれらが表示され、選択するこ

とができるようになります。 

DIA-Umpire, RawConverter(Scripps)、pXtract は、raw データを

通常の変換とは異なる特殊な前処理(DIA→DDA 変換など)を行うプログラムです。他の通常の変換プログラム同様、必要に   

応じてプログラムのファイルパスを指定してください。 

Windows のコマンドライン実行形式プログラムであれば、フィルタプログラムとして[Data import filter]タブに追加する 

事ができます。詳しくは Mascot Daemon のメニューバー[Help]→[In Depth]→[Data Import Filter]→[Add a new filter]を 

ご覧ください。 

 

 

図 4-2 [Intranet]タブ 

図 4-3 [Data import filters]タブ 
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(3) [ODBC connection]タブ 

Mascot Daemonと Task databaseファイルをどのように接続する

かを定義します。Database engine、ODBCドライバー、Task database

ファイルパスの組み合わせになりますが、詳しい構成方法に関して

は Mascot Daemon のメニューバー[Help]→[Getting Started]→

[Database Engines]をご覧ください。  

 

 

 

 

 

 

(4) [Timer settings]タブ 

Mascot Daemonの応答時間を変更することができますが、設定値

によっては Mascot Daemon によって PCのリソースが消費され、PC

の操作性が低下することがありますので注意してください。 

[Timer tick interval] 

タスクは独自のタイマーを持っており、ここで設定した時

間間隔毎にタスクの進捗状況をチェックします。この動作は

PC のリソースを消費するため、短い時間は設定しないでくだ

さい。設定範囲は 1～60、推奨値は 10です。 

[Delay after opening empty dataset] 

フィルタプログラムからの出力が無くなってからの時間

を指定します。動作に問題がなければ 0 を指定することもで

きます。設定範囲は 0～3600、推奨値は 10 です。 

[File size must be constant for at least] 

リアルタイムモニター・モードにおいて、質量データファイルの作成プロセスが完了したかどうかのチェック間隔時間

を指定します。推奨値は 60です(10 以下の値は設定しないでください。逆に、60 でエラーが発生する場合はこの値を大き

くしてください)。 

[Minimum delay between monitor searches] 

リアルタイムモニター・モードにおいて、指定した質量データファイルの存在チェック間隔時間を指定します。推奨値

は 60 ですが、ファイル群の存在場所(ローカルディスクあるいはネットワーク上のディスク)やワイルドカードにマッチ

するファイル数によって最適値は異なります。ローカルディスク上に存在する少数のファイルに対しては 10 程度の値で

問題ありません。 

[Minimum delay between follower searches] 

フォローアップ・モードにおいて、質量データファイルの存在チェック間隔時間を指定します。推奨値は 60 です(動作

に問題がなければ 60 未満の値を設定することができます)。 

[Take action polling interval] 

Mascot Daemon Service プログラムがタスク・データベース(TaskDB.mdb)をチェックする時間間隔です。推奨時間は 15

秒です(10以下には設定しないでください)。 

 

 

 

図 4-4 [ODBC connection]タブ 

図 4-5 [Timer settings]タブ 
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(5) [Authentication]タブ 

Mascot Server のセキュリティー設定が有効になっており、ユー

ザ名とパスワードでログインする必要がある場合は [Mascot 

Security]フレームにその内容を入力してください。他のユーザ名で

も検索することができるユーザ権限を設定している場合は、[Task 

Editor]タブの[Owner]フレームがアクティブになり、ドロップダウ

ンリストから許可されたユーザ名を選択することができます。 

Web サーバがユーザ名とパスワードを要求するように設定されて

いる場合は[Web Server Authentication]フレームにその内容を入力

してください。同様に、プロキシサーバがユーザ名とパスワードを

要 求 す る よ う に 設 定 さ れ て い る 場 合 は [Proxy Server 

Authentication]フレームにその内容を入力してください。 

 

(6) [General]タブ 

検索パラメータをテキストファイルとして保存するか、Task 

databese に格納するかを選択することができます。 

Mascot Distillerは CPUリソースのすべてを使ってピーク抽出処

理や定量計算を実行するため、Mascot Daemonの反応が鈍くなります

ので、「Below normal」または「Low」を選択して Mascot Distiller

の CPU リソース使用優先度合いを下げることができます。 

 

 

 

 

4.3 [Parameter Editor]タブ 

検索条件を設定し、設定した内容を検索条件ファイル(*.par)と

して保存します。作成した検索条件ファイルは[Task Editor]タブ

の[Parameter set]フレームで使用します。Mascot Daemonを起動す

ると自動的に default.par ファイルが読み込まれ、その内容が検索

条件として反映されます。 

(1) [Parameter set]フレーム 

[Filename] 

現在読み込まれている検索条件ファイル名が表示されま

す。 

[New]ボタン 

表示されている検索条件を破棄し、新たに検索条件を設定

したい場合に押してください。 

[Open …]ボタン 

すでに保存してある検索条件ファイルを読み出したい場合に押してください。 

[Save]ボタン 

表示されている検索条件を default.par ファイルとして保存したい場合に押してください。 

 

図 4-6 [Authentication]タブ 

図 4-8 [Parameter Editor]タブ 

図 4-7 [General]タブ 
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[Save As …]ボタン 

表示されている検索条件を新しいファイル名で保存したい場合に押してください。 

(2) [All Searches]フレーム 

PMF検索および MIS 検索に共通する検索条件を指定します。 

[User name]、[User email] 

ユーザ名、電子メールアドレスを入力してください。Mascot セキュリティーが有効になっている場合は次のタグを使用

することができます。なお、タグを構成する文字は大文字小文字を区別します。 

<mascot_user_name>：ユーザ名に置き換えます。 

<mascot_user_full_name>：ユーザのフルネームに置き換えます。 

<mascot_user_email>：ユーザの電子メールアドレスに置き換えます。 

[Search title] 

ここで入力した内容は検索結果ページの[Search title]行に表示されます。また、次のタグを使用することができます。

<mascot_user_*>(*=id, name, full_name, email)は Mascotセキュリティーが有効になっている場合に機能します(Mascot

セキュリティーが無効の場合は、検索結果ページの対応する行はブランクになります)。なお、タグを構成する文字は大文

字小文字を区別します。 

① <taskname>：タスク名に置き換えます。 

② <parameters>：検索条件ファイル名に置き換えます。 

③ <localhost>：PCのホスト名に置き換えます。 

④ <localuser>：Windows ログインユーザ名に置き換えます。 

⑤ <datafilename>：質量データファイル名に置き換えます。 

⑥ <datafilepath>：質量データファイルパス名に置き換えます。 

⑦ <cachedpeaklist>：フィルタプログラムが作成するピークリストファイルパス名に置き換えます（存在する場合）。 

⑧ <samplenumber>：サンプル番号に置き換えます(存在する場合)。 

⑨ <mascot_user_id>：ユーザ IDに置き換えます。 

⑩ <mascot_user_name>：ユーザ名に置き換えます。 

⑪ <mascot_user_full_name>：ユーザのフルネームに置き換えます。 

⑫ <mascot_user_email>：ユーザの電子メールアドレスに置き換えます。 

[Taxonomy] 

検索対象としたい生物種を選択してください。 

[Report Top] 

検索結果ページに表示させたいヒットしたタンパク質数を選択してください。 

AUTO を選択した場合は、有意なスコアを持つタンパク質が表示されます(「Protein Summary Report」の表示モードで

は、有意なスコアを持つタンパク質と、閾値スコアを超えない閾値スコアに最も近いタンパク質を表示しますので、有意

なスコア持つタンパク質が得られない検索結果においては、最も高いスコアを持つタンパク質を表示します)。 

[Database] 

検索対象としたい配列データベースを選択してください。[Ctl]キーを押しながら複数の配列データベースを選択する

ことができます。 

[Enzyme] 

タンパク質を消化するために使用した消化酵素を指定してください。 

「None」を選択した場合は、全ての「部分アミノ酸配列(sub-sequence)」に対して(すなわち、全ての切断特性を考慮し

て)検索を実行しますので、検索対象となるペプチドの数は「Trypsin」の場合と比較して数桁多くなるため、検索時間は

増加し、閾値スコアは相対的に高くなります。HMC ペプチドのような、消化酵素由来ではない生体内ペプチドに対して検

索したい場合は「None」を選択してください。 

「Trypsin」などの消化酵素を指定した検索で有意なタンパク質がヒットしないときは、「None」を選択する前に

「semiTrypsin」を選択して再検索するほうが効率的です。「semiTrypsin」は「Trypsin」と「None」の中間的な切断特性
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を持っており、K および Rの C 末側で切断し(Kおよび R の次に P が存在する場合は切断しません）、N末端側は任意に切断

します。C末端、N末端で任意に切断されていると考えられる場合は「None」を選択してください。 

注意：CNBrを選択した場合は、Variable modifications リストから「Met->Hsl(Homoserine lactone)」あるいは「Met-

>Hse(Homoserin)」を選択してください。 

[Max. Missed Cleavages] 

ペプチドの未切断サイト数を選択してください。 

酵素消化によって得られたペプチド混合物の中に未消化サイトを持つペプチドが存在する場合は、そのサイト数(実験

条件にもよりますが、通常は「１」あるいは「２」程度)を選択してください。タンパク質が完全に酵素消化され、試料中

に不完全に消化されたペプチド断片は存在しないと断言できる場合は「０」を選択してください。検索対象となるペプチ

ド数がより少なくなるため、閾値スコアは相対的に小さくなります。明確な理由なしに大きな値を選択するのは避けてく

ださい。値が大きくなるほど検索対象となるペプチド数は増加し(したがって検索時間も増加し)、閾値スコアは相対的に

高くなります。 

[Select Modifications] 

[Select Modifications]ボタンを押すと図 4-9に示すダイ

アログが表示されます。左側の修飾リストから目的の修飾を

選 択 し 、 [Fix Modifications] 欄 あ る い は [Variable 

Modifications]欄の左横にある[ ＞ ]ボタンを使って移動

してください。[ ＜ ]ボタンで元に戻すことができます。 

Mascot Server は 、 化 学 修 飾 に 対 応 す る 「 Fixed 

modifications」と翻訳後修飾あるいは偶発的な修飾に対応

する「Variable modifications」とを区別しています。 

[Fixed modifications]として指定されたアミノ酸残基ま

たはアミノ酸末端は、すべてその修飾を受けたものとして検

索が実行されます。たとえば、「Carboxymethyl (C)」を選択

した場合は、システインの質量(103 Da)は修飾を受けた質量

である 161 Da(103-1+59)として検索が実行されます。アミノ酸残基またはアミノ酸末端は、その修飾を受けた時の質量で

固定されますので、検索時間の増加はありません。 

一方、[Variable modifications] として指定されたアミノ酸残基またはアミノ酸末端は、その修飾を受ける場合と受け

ない場合の２通りを考慮した検索が実行されます。たとえば、「Oxidation (M)」を選択した場合、もしペプチドの中に３

つのメチオニンが存在するときは、０、１、２、３個の酸化メチオニン残基の存在を考慮し、質量データに最もよく一致

する検索結果を表示します。[Variable modifications]を加味した検索はタンパク質同定においては非常に強力な手法で

すが、選択する修飾の数に比例して検索対象となるペプチドの数が幾何級数的に増加し(検索時間も級数的に増大し)、閾

値スコアは相対的に高くなるため、有意な同定結果が得にくくなります。一般的に、試料に含まれるペプチドのうち一部

のペプチドが翻訳後修飾を受けていると考えられますので、第１段階の検索では、[Variable modifications]の選択数を

ゼロまたは最小限にとどめて、まず試料に含まれると思われる有意なタンパク質を同定し、第２段階の検索で、同定した

タンパク質に対して構造解析を行うという検索プロセスがより効率的です。 

なお、デフォルトの状態では代表的な修飾がリストに表示されています。Mascot Server に設定されている全ての修飾

を表示させたい場合は[Show all modifications]をチェックしてください。 

[Decoy database] 

Decoy データベースに対する検索を自動実行させたい場合はチェックしてください。主に FDR(False Discovery Rate)

を確認したいときに使用します。詳しくは次のページをご覧ください。 

     http://www.matrixscience.com/help/decoy_help.html 

[Protein Mass] 

指定した質量以下の連続したアミノ酸配列に対して検索を実行します。入力欄が空欄の場合はこの機能は無効です。た

とえば、10,000 Da を指定した場合は、10,000 Da の「長さ」を持つウインドウが配列データベース上を移動するイメージ

になります。従いまして、検索対象は、分子量１万以下のタンパク質エントリと、分子量が 1 万以上のタンパク質エント

図 4-9 [Select Modifications]ダイアログ 
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リに対しては質量値が 1 万以下の連続した部分アミノ酸配列となります。 

[Peptide Charge] 

通常は使用しません。質量データにプリカーサイオンの電荷情報が含まれない場合は対応する電荷を選択してください。 

[Monoisotopic / Average] 

質量データがモノアイソトピック(12 C)の場合は[Monoisotopic]を、平均値の場合は[Average]を選択してください。 

[Peptide tol. ±] 

ペプチド分子またはイオンの質量誤差を指定してください。次の単位をサポートしています。 

① % 

② mmu (milli-mass units、0.001Da) 

③ ppm 

④ Da 

[#13C] 

抽出されたピークがモノアイソトピック(12 C)ではなく「13 C」あるいは「13 C 2」が含まれる場合にはリストから１また

は２を選択してください。質量誤差は、 

   質量誤差 ＞ ｜実験値－理論値－1 または 2｜ 

で計算されます。 

(3) [MS/MS]フレーム 

MIS検索の検索条件を指定します。 

[MS/MS Ions Search] 

チェックすると MIS 検索が有効になります。 

[Data format] 

質量データファイルのファイルフォーマットを指定してください。次のファイルフォーマットをサポートしています。 

① Mascot generic (.MGF) 

② Finnigan (.ASC) 

③ Micromass (.PKL) 

④ Sequest (.DTA) 

⑤ mzData (.XML) 

⑥ mzML (.mzML) 

[Quantitation] 

定量解析手法を選択してください。 

[Error tolerant search] 

Error Tolerant 検索を自動実行させたい場合はチェックしてください。なお、次の制限がありますので注意してくださ

い。 

① 消化酵素を指定しなければいけない。 

② 「Variable modification」の指定数は２個まで(設定ファイル「mascot.dat」中で変更することができます）。 

③ Decoy 検索との併用はできない。 

④ Quantitation検索との併用はできない。 

[MS/MS tol. ±] 

プロダクトイオンの質量誤差を指定してください。次の単位をサポートしています。 

① mmu（milli-mass units、0.001Da） 

② Da 

[Instrument] 

質量分析計のタイプを選択してください。質量分析計のタイプに対応するプロダクトイオンの種類(イオンシリーズ)に
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ついては次のページをご覧ください。 

http://www.matrixscience.com/help/search_field_help.html#INSTRUMENT 

[Crosslinking] 

クロスリンクの解析手法を選択してください。定量解析手法同様、使用時には予め MASCOT Server 上で設定を作成して

パッケージ化しておく必要があります。 

4.4 [Task Editor]タブ 

タスクを作成し、Mascot検索を実行します。 [Task]フレームの

入力欄(デフォルトは「Untitled」）に文字列を入力してタスク名を

設定してください。それぞれのタスクにはタスク ID（通し番号）が

付けられます。タスク名は[Status]タブおよび[Event Log]タブ内

でタスク ID とともに表示されます。タスクには次の 3 種類の動作

モードがあり、それぞれ[Data file list]フレームのレイアウトが

異なります（図 4-10 はバッチ・モードのフレームレイアウトです）。 

バッチ・モード (batch) 

指定した(１つまたは複数の)質量データファイルをひとつず

つ、順番に Mascot 検索を実行します。Mascot 検索開始日時を指

定することもできます。 

リアルタイムモニター・モード (Real-time monitor) 

指定したフォルダ（ローカルあるいはネットワーク上）を監視し、そのフォルダに新たに作成された質量データファイルを

取得し、Mascot検索を実行します。すなわち、質量分析計のデータ処理ソフトウエアが作成した質量データは、Mascot Daemon

を介して自動的に Mascot Server に投入されますので、タンパク質同定にかかわる質量データ処理プロセスを自動化するこ

とができます。 

フォローアップ・モード (Follow-up) 

検索結果のスコアあるいは期待値が、あらかじめ指定した条件に達しなかった場合、別の検索条件で再検索を実行します。 

(1) [Owner]フレーム 

Mascot セキュリティーが有効になっており、他のユーザ名でも検索することができるユーザ権限を設定している場合にア

クティブになります。ドロップダウンリストからユーザ名を選択してください。 

(2) [Task]フレーム 

入力欄（デフォルト値は「Untitled」）にタスク名を入力してください。ここで入力したタスク名は[Status]タブ、[Event 

Log]タブ、検索結果ページの[Search title]行に表示されます。[Status]タブ内に表示されているタスクの「Clone」を作成

した場合は、タスク名の前に「Copy of」が加えられます。[New]ボタンは設定内容をデフォルトに戻します。[Run]ボタンを

押すとタスクが実行されます。 

(3) [Parameter set]フレーム 

[…]ボタンを押して、[Parameter Editor]タブで作成・保存された検索条件ファイル（*.par）を読み込んでください。検

索条件ファイルが保存されるデフォルトのフォルダは「C:\ProgramData\Matrix Science\Mascot Daemon\parameters」です。 

(4) [Data import filter]フレーム 

質量データファイルが質量分析計ベンダー独自のバイナリ形式（拡張子が .raw や .wiffなど）の場合は、対応するフィ

ルタプログラムを使って質量ピーク抽出処理を行った後に Mascot検索を実行する必要があります。ドロップダウンリストか

ら質量データファイルに対応するフィルタプログラムを選択し、その右にある[Options …]ボタンを押してください。ピー

ク抽出などの処理条件を設定するためのダイアログが表示されますので、処理条件を設定した後、[OK]ボタンを押してくだ

さい。[Run]ボタンを押すと、質量データファイルはフィルタプログラムでピーク抽出処理され、作成されたピークリストが

図 4-10 [Task Editor]タブ 



Mascot Daemon 2.7 取扱説明書 | 23 
  

                                            
マトリックスサイエンス株式会社 

Mascot Server に投入されます。デフォルトでは次のフィルタプログラムをサポートしています。 

 

 

① Mascot Distiller 

Mascot Daemonがインストールされている PCに Mascot Distiller

がインストールされている場合に表示されます。全ての質量分析計

ベンダーの質量データファイルを処理することができます。 

「Mascot Distiller」を選択した後、[Options …]ボタンを押す

と図 4-11 に示すダイアログが表示されますので、[Data File 

Format]フレームから質量データファイルのファイルフォーマット

を選択し、[…]ボタンから適切な処理条件ファイル（Processing 

Options ファイル：*.opt）を読み込んでください。[Multi-Sample 

Files]フレームは AB | MDS Sciexの Analyst .WIFF ファイル用の

設定項目です。WIFF ファイルが複数のサンプルデータから構成され

ている場合の検索方法(統合か個別か)を指定することができます。

[Scan Range (multi-scan files)]フレームでは、データ処理の範

囲を LC の保持時間や質量分析計のスキャン番号で指定することが

できます。[Output MS/MS Fragment as]フレームでは、出力データとしてのプロダクトイオンの電荷を指定することが

できます。Mascot Server はプロダクトイオンの電荷を１価あるいは２価と仮定して検索しますので、３価以上のプロ

ダクトイオンが存在する場合は「MH+」を選択し、多荷のプロダクトイオンの m/z 値を１価の質量に変換して出力する

ようにしてください。[Distiller Project File]フレームの[Save]をチェックすることにより、Mascot Distiller の処

理内容をプロジェクトファイル(*.rov)として自動的に保存します。定量計算を行った場合は、計算対象となるタンパ

ク質の範囲（[Range]の場合はヒット番号）を指定してください。 

② Thermo ExtractMSn  

Mascot Daemon がインストールされている PC に ExtractMSnとそ

の関連ファイルがインストールされおり、メニューバー[Edit]→ 

[Preferences]→[Data import filters]タブの[Full path to 

Thermo ExtractMSn]入力欄にそのファイルパスが指定されている場

合に表示されます。Xcalibur RAWファイルを処理（プリカーサ毎の

DTA ファイルを作成し、それらをひとつにまとめて MGF ファイルを

作成）することができます。 

[Data import filter]から「Thermo ExtractMSn」を選択した後、

[Options …]ボタンを押すと図 4-12 に示すダイアログが表示され

ますので、適切な処理条件を設定し、[OK]ボタンを押してください。

詳しくは Mascot Daemon のメニューバー[Help]→[Mascot Daemoon 

Help]→[In Depth]→[Data Import Filters]→[Thermo ExtractMSn]

の項をご覧ください。また併せて次のページもご覧ください。 

http://www.matrixscience.com/help/instruments_xcalibur.html 

 

 

 

 

 

図 4-11 Mascot Distiller 

図 4-12 Thermo ExtractMSn 
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③ AB SCIEX MS Data Converter 

Mascot Daemon がインストールされている PCに AB SCIEX MS Data 

Converter がインストールされおり、メニューバー[Edit]→ 

[Preferences]→[Data import filters]タブの[Full path to AB 

SCIEX MS Data Converter]入力欄にそのファイルパスが指定されて

いる場合に表示されます。Wiff および TOF/TOF データを処理するこ

とができます。 

[Data import filter]から「AB SCIEX MS Data Converter」を選

択した後、[Options …]ボタンを押すと図 4-13 に示すダイアログ

が表示されますので、適切な処理条件を設定し、[OK]ボタンを押し

てください。詳しくは Mascot Daemon のメニューバー[Help]→

[Mascot Daemoon Help]→[In Depth] →[Data Import Filters]→

[AB Sciex MS Data Converter]の項をご覧ください。また併せて次

のページもご覧ください。 

http://www.matrixscience.com/help/instruments_analyst.html#Converter 

④ ProteoWizard msConvert 

 Mascot Daemon がインストールされている PC に ProteoWizard 

msConvert がインストールされおり、メニューバー[Edit]→ 

[Preferences]→ [Data import filters]タブの[Full path to 

ProteoWizard msConvert]入力欄にそのファイルパスが指定されて

いる場合に表示されます。様々なフォーマットの質量データファイ

ルを処理することができます。 

http://proteowizard.sourceforge.net/doc_users.html 

[Data import filter]から「ProteoWizard msConvert」を選択し

た後、[Options …]ボタンを押すと図 4-14 に示すダイアログが表

示されますので、適切な処理条件を設定し、[OK]ボタンを押してく

ださい。入力する質量データファイルのフォーマットは自動で認識

され、「MGF」あるいは「mzML」のフォーマットで出力されます。詳

しくは Mascot Daemon のメニューバー[Help]→[Mascot Daemoon 

Help]→[In Depth] →[Data Import Filters]→[ProteoWizard msConvert]の項をご覧ください。 

(5) [Data file list]フレーム 

タスクの種類(動作モード)により、フレームレイアウトが異なります。 

①  バッチ・モード 

図 4-13 AB SCIEX MS Data Conveter 

図 4-14 ProteoWizard msConvert 
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[Schedule]フレームの[Start now]または[Start at]

または[Start on completion of]が選択されている場合

の動作モードです。ひとつまたは複数の質量データファ

イルに対して、逐次的に Mascot 検索を実行します。

[Start on completion of]では、指定した検索中ないし

予定されているバッチ・モードの検索が終わった後に

Mascot 検索を実行します。質量データファイルは[Add 

Files …]ボタンを押して表示されるダイアログから指

定してください。[Data import filer]でフィルタプログ

ラムを選択した場合は[Add Folder …]ボタンも有効に

なり、「Masslynx」、「Bruker XMASS/XTOF」、「Bruker 

Esquire」、「Agilent LC/MSD Trap」などのフォルダ単位

の質量データを指定することができます。また、Windows のファイルブラウザ上で選択したファイル群またはフォル

ダ群を[Data file list]ウインドウにドラッグ＆ドロップすることもできます。 

[Data file list]ウインドウに読み込んだ質量データファイルまたはフォルダを削除する場合は、削除したいファ

イルまたはフォルダを選択し、[Delete]ボタンを押してください。 

[Merge MS/MS files into single search]をチェックすると、[Data file list]ウインドウにある全ての質量デー

タファイルを結合してひとつにし、Mascot 検索を実行します(XML 形式のデータファイルは統合できません)。[Data 

import filter]でフィルタプログラムが指定されているときは、フィルタプログラムによって処理された質量データ

ファイルが「C:\ProgramData\Matrix Science\Mascot Daemon\MGF\タスク名\mascot_daemon_merge.mgf」ファイルと

して統合されます。なお、フィルタプログラムとして「Mascot Distiller」を指定したときは、[Status]タブには Mascot 

Distiller Project ファイルのリンクは表示されませんが、各質量データファイルに対するプロジェクトファイルは

「C:\ProgramData\Matrix Science\Mascot Daemon\MGF\タスク名」フォルダに保存されています。 

フィルタプログラムとして「AB SCIEX MS Data Converter」を指定したときは、[Add Folder …]ボタンではなく

[Job Run …]ボタンになります。[Job Run …]ボタンを押すとテキストを入力するためのダイアログが表示されます

ので、「4800\ProteinPilot Getting Started Guide\iTRAQ Reagents - 8Plex 8 Protein Mix\3\1\2」のような Pseude

パスを入力してください。 

② リアルタイムモニター・モード 

[Schedule]フレームで[Real-time monitor]が選択さ

れている場合の動作モードです。リアルタイムモニタ

ー・モードでは、ワイルドカードを含むフォルダパスや

ファイルパスを使って質量データファイルを指定しま

す。[New files only]をチェックすると、タスクを実行

した時点ですでに存在した質量データファイルは無視

されます。[Include sub-folders]をチェックすると、

[Specify path to root folder]欄で指定したフォルダ

およびそのサブフォルダに存在する質量データファイ

ルに対して検索を実行します。 

なお、ワイルドカードにより指定されるファイル数は

非常に多くなる場合がありますので、もしタスクを実行

した後に指定内容の間違いに気づいた場合はそのタスクを強制終了してください([Status]タブに移動し、対応する

タスク名を右クリックし、[Pause]を選択した後に[Delete]を選択してください)。 

ワイルドカード(「*：任意個の文字」および「?：１個の文字」)の使用例を示します。[Specify path to root folder]

欄で「D:\Data\P*\Q*\200311??」のように指定した場合、 

D:\Data\Proteins\QStar\20031102 

D:\Data\Peptides\QTrap\20031103 

図 4-15 [Start now/at/on completion of]モードのフレーム 

図 4-16 [Real-time monitor]モードのフレーム 
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などのフォルダパスが対象となりますので、[Optional wild card file or name]欄で「*.wiff」を指定することに

より、これらの指定内容に一致する次のような質量データファイルが検索対象となります。 

 D:\Data\Proteins\QStar\20031102\Trypsin234.wiff 

質量データファイルを含むフォルダを対象としたい場合、たとえば、 

 D:\Data\Proteins\QTof\Default.pro\Data\Trypsin234.raw 

フォルダの場合は、[Specify path to root folder]欄で「D:\Data\Proteins\QTof\*.pro\Data」を、[Optional wild 

card file or name]欄で「*.raw」のように指定することができます。しかし、[Specify path to root folder]欄で

「D:\Data\Proteins\QTof\*.pro\Data\*」を指定し、[Optional wild card file or name]欄を空欄にした場合は、対

象となるフォルダ階層が深すぎるため（すなわち「D:\Data\Proteins\QTof\*.pro\Data\*\*」を指定することになり）、

動作しません。 

[Include sub-folders]をチェックした場合は、[Specify path to root folder]欄で指定したフォルダ及びそのサ

ブフォルダに存在する質量データファイルが検索対象となりますが、検索対象がフォルダの場合は動作しません。 

なお、「AB SCIEX MS Data Converter」を使って Oracleデータベースから取得した TOF/TOF データに対しては、動

作しません。 

③ フォローアップ・モード 

[Schedule]フレームで[Follow-up]が選択されている

場合の動作モードです。フォローアップ・モードで作成・

実行されたタスクは「アイドリング状態」で待機し、他

のタスクで指定されたフォローアップ条件に合致した結

果として回されてきた質量データファイルに対して

Mascot検索を実行しますので、[Data file list]フレー

ムは使いません。複数のフォローアップ・タスクを組み

合わせ、より複雑な検索処理プロセスを作成することが

できます。 

(6) [Schedule]フレーム 

タスクの種類(動作モード)を指定します。 

[Start now]と[Start at]と[Start on completion of]はバッチ・モードに対応します。 

[Real-time monitor]はリアルタイムモニター・モードに対応します。 

[Follow-up]はフォローアップ・モードに対応します。 

[Search priority]は実行したタスクの優先順位を指定します。[0]から[-20]の値を指定することができ、数値が小さいほ

ど優先順位が低くなります。 

(7) [Actions]フレーム 

図 4-17 [Follow-up]の[Data file list]フレーム 
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[Auto-export]ボタンを押すと、図 4-18 に示すダイアログが

表示されますので、[Choose first]で検索モード（PMF または

MS/MS）を、[Choose second]で出力フォーマットを選択し、

[Format]フレームで出力したい項目をチェックした後、ページ

の最後にある[OK]ボタンを押してください。Mascot 検索が終了

した後に、指定された出力フォーマットで検索結果の内容が

「C:\ProgramData\Matrix Science\Mascot Daemon\MGF\タスク

名」フォルダにファイル出力されます。なお、出力項目は Mascot

検索が実行される前に設定されていますので、Mascot 検索結果

がその出力項目を含まない場合はエラーが返されることがあり

ます。Mascot 検索の条件や内容を考慮して出力項目を選択して

ください。 

[External processes] ボ タ ン を 押 す と [Mascot Daemon 

External processes]ダイアログが表示されます。動作させたい外部プログラムを、 

① タスクの開始前 (Before starting task) 

② 検索の実行前 (Before each search) 

③ 検索終了時 (After each search) 

④ タスクの終了時 (After completing task) 

の各ポイントで指定し、実行させることができます。なお、ここで設定した内容はタスクの構成情報として、タスク毎に記

録されます。 

[Wait for completion]をチェックした場合は、外部プログラムが終了するのを待つことになりますが、もし外部プログラ

ムが正常終了せずに固まった状態（hung）になった場合は、タスクはそれに引きずられ先に進みません。もし、外部プログラ

ムがエラーを出力して停止した場合は、そのエラーは Event Log 欄に出力され、Task は次のステップへと進行します。 

[Halt on error]をチェックした場合は、外部プログラムがエラーを出力して停止した時点でタスクは途中終了します。 

なお、External processes機能は Mascot Daemon Engineプログラムが管理しています。もし、Mascot Daemon Engineプ

ログラムを Windows のサービスプログラムとして動作させていて、外部プログラムがデスクトップ・アプリケーションの場

合は、Mascot Daemon Engine サービスプログラムがこの外部プログラムを実行できるように設定してください。 

External processes では次のタグを使用することができます。<resulturl>タグのように、処理が終了するまで値を持たな

いものがあります。また、タグは大文字小文字を区別します。 

<taskname>：タスク名 

<parameters>：検索条件ファイルパス 

<localhost>：コンピュータ名 

<localuser>：ログオンユーザ名 

<datafilename>：質量データファイル名 

<datafilepath>：質量データファイルパス 

<cachedpeaklist>：「Data import filter」プログラムが作成したピークリストファイルパス 

<samplenumber>：サンプル番号 

<mascot_user_id>：Mascotセキュリティユーザ ID 

<mascot_user_name>：Mascot セキュリティユーザ名 

<mascot_user_full_name>：Mascot セキュリティユーザフルネーム 

<mascot_user_email>：Mascotセキュリティユーザメールアドレス 

<resulturl>：検索結果ページ URL 

<resultfilename>：検索結果ファイル名 

<resultfilepath>：検索結果ファイルパス 

図 4-18 Auto-export の詳細設定 
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External processes の設定例を示します。図 4-19 の上段に示した

設定の下でタスクを実行すると、タスクが開始される前に、net コマン

ドを使って PC のログインユーザである「<localuser>」に「タスク名 

is starting」のメッセージを送り(PC のディスプレイ上にはこのメッ

セージを含むダイアログが表示されます)、Mascot 検索が終了した時

点で検索結果ページを読み込んだブラウザが起動し、タスクが終了し

た時点で「<localuser>」に「タスク名 has finished」のメッセージ

を送ります。なお、Web ブラウザはデスクトップ・アプリケーションで

すので、Mascot Daemon Engine プログラムがサービスプログラムとし

て動作している場合は、デスクトップ・アプリケーションを実行でき

るように設定してください。 

図 4-19 の下段は「Microsoft Windows Script」を使用した例です。

上段の例と同様に、タスクを実行すると、タスクの開始時及び終了時

に net コマンドを使って PC のログインユーザである「usami」にメッ

セージ(「タスク名 is starting」と「タスク名 has finished」)を送

りますが、同時に「C:\temp\links.txt」ファイルが作成され、各々の

Mascot検索に対する検索結果ページの URLが一行ずつ追加されていき

ます。ここで使用した simple.vbsスクリプトは次のような内容を持っ

ています。また、ここで使用したスクリプトはデスクトップ・アプリ

ケーションではありません。 

<スクリプトファイル名：simple.vbs> 

Option Explicit 

'Result file name and result URL are passed as command 

line arguments 

Dim objArgs, ResultFileName, ResultURL 

Set objArgs = WScript.Arguments 

ResultFileName = objArgs(0) 

ResultURL = objArgs(1) 

'Format result URL as hyperlink and append to links file 

Dim fso, MyFile, ForAppending 

ForAppending = 8 

Set fso = CreateObject("Scripting.FileSystemObject") 

Set MyFile = fso.OpenTextFile("c:\temp\links.txt", ForAppending, True) 

MyFile.WriteLine "<A HREF=" & CHR(34) & ResultURL & CHR(34) & ">" & ResultFileName & "</A>" 

(8) [Follow-up]フレーム 

再検索を実行するための条件を設定します。 

再検索条件として[If score less than]を選択してスコアの

値を、[If probability that match in random > 1]を選択して

期待値の値(0.05を指定したい場合は 20 を入力)を設定します。

検索結果のスコアが指定値を下回った場合(検索結果の期待値

がその値を上回った場合)に、その質量データファイルは

[Repeat at intervals of]で指定した時間間隔で再検索される

か、あるいは[Pass data to]で指定した(あらかじめ実行してあ

る)フォローアップ・タスクに渡され、その検索条件に従って再検索されます。 

フォローアップ機能は様々な目的に利用することができます。 

(例１) 設定したスコアまたは期待値に達しなかった質量データファイルに対し、指定した時間間隔で再検索させるよ

図 4-20 [Follow-up]フレーム 

図 4-19 [External processes]の設定例 
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うにすることができます。再検索は設定条件を満たさなくなるまで無期限に続けられます。データベースが定

期的に更新される場合などに有効です。 

(例２) ひとつの質量データファイルに対して、異なる複数の配列データベースを検索させることができます。たとえ

ば、最初に NCBInr データベースを検索させ、設定したスコアあるいは期待値に達しなかった場合は dbEST デ

ータベースを再検索させることができます。 

[Discard results]をチェックすると、[Status]タブの検索結果ツリーには各々の検索結果は追加されなくなりますが、設

定したスコアあるいは期待値に達しなかった検索の場合は、[Event Log]タブにその内容を伝えるメッセージ（たとえば

「Search results discarded (score is less than 61 specified threshold)」)が表示されます。 

[Repeat at interval of]をチェックすると、設定したスコアあるいは期待値に達しなかった質量データファイルは指定し

た間隔(分、時間、日、週、月)で再検索されます。 

[Pass data to]をチェックすると、設定したスコアあるいは期待値に達しなかった質量データファイルはリストから選択

したフォローアップ・タスクに渡され、再検索されます（フォローアップ・タスクはあらかじめ実行し、“アイドリング状態”

にしておく必要があります）。 

4.5 [Event Log]タブ 

[Event Log]タブには Mascot Daemon が実行したイベントに関す

るログ情報が表示されます。warning や error に関するメッセージ

もここに表示されます。表示されるログ情報は Mascot Daemon が

起動した時点から始まります。過去のログはカンマで区切られた

CSVファイルの形式で次のファイルに記録されます。なお、Mascot 

Daemon Serviceプログラムの出力メッセージは Windows Event Log

に記録されるもこともありますので、必要に応じて確認してくださ

い。 

C:\ProgramData\Matrix Science\Mascot Daemon\Mascot_Daemon_Event_Log.csv 

4.6 [Status]タブ 

[Status]タブでは、[Task Database]、[タスク名]、[質量データ

ファイル名]の関係をツリー構造で表示するとともに、タスクの状

態や検索結果の概要を確認することができます。 

左側ウインドウの最上位に位置する[Task Database]を選択する

と、右側ウインドウにはそれに含まれるタスクに付随する情報が一

覧表示されます。左側ウインドウの[タスク名]を選択すると、右側

ウインドウにはそれに含まれる検索概要(質量データファイル名や

検索結果 URL など)がリスト表示されます。左側ウインドウの[質量

データファイル名]を選択すると、右側ウインドウにはその検索の

概要が表示されます。なお、右側ウインドウの最上位にあるタイト

ルカラムをクリックすると、表示されているリストの並びを昇順・

降順に切り替えることができます。また、タイトルカラムの幅は境

界線をマウスでドラッグすることにより変更することができます。 

図 4-21 [Event Log]タブ 

図 4-22 [Status]タブ 
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タスクの状態は、タスク名の左側にあるアイコンで確認することができます。各アイコンは次の意味を持っています。 

タスクは一時停止(Pause)、再検索(Resume)、複製(Clone)、削除(Delete)することができます。タスク名を右クリックし、表

示されたリストから実行したい操作を選択してください（あるいは、タスク名をクリックし、下方に配置されているボタンを押

してください）。 

[Clone]を選択することにより、そのタスク情報は[Task Editor]タブに「Copy of タスク名」として複製されますので、類似

の条件を持った新しいタスクを作成するときに便利です。 

[Delete]を選択してタスク全体を削除できますが、タスクにぶら下がっている個々の[質量データファイル名]を削除すること

はできません。また、タスクを削除すると Mascot Daemon が管理するタスク・データベースファイルからその情報が削除されま

すが、Mascot Server が管理する結果ファイルが削除されることはありません。 

[質量データファイル名]をドラッグして、[フォローアップ・タスク名]にドロップすると、そのフォローアップ・タスクの条

件で再検索を実行することができます。 

[Status]タブの画面は[Task action polling interval (seconds)]の設定値([Edit]→[Preferences]→[Timer settings]タ

ブ)に従ってリフレッシュされます。リフレッシュする毎にタスク・データベースファイルを読み込み、PC のリソースを消費し

ますので、この設定値は小さくせずに、必要に応じて[Refresh (F5)]ボタンを押してください。 

ひとつのタスク・データベースファイルは異なる PC にインストールされた複数の

Mascot Daemon で共有することができます。それぞれのタスクはそのタスクを作成した

Mascot Daemonが所有者になり、タスクの一時停止(Pause)、再検索(Resume)、削除(Delete)

を行うことができますが、複製(Clone)は全てのクライアントに許可されています。  

ステータスツリーに多くのタスクがある場合、特定のタスクを見つけるのが難しい場合が

あります。[Filter...] ボタンをクリックするとダイアログが表示され、様々な条件で表

示をフィルタリングすることができます。ドロップダウンリストは、「--- Any ---」以外

に設定されている場合にアクティブになります、エディットボックスの場合は空でなく何

か文字が記されている場合にアクティブになります。アクティブなフィルタをすべて満た

すタスクがない場合、ツリーは空になります。これは単に表示上のフィルタであることに 

注意してください。実行中のタスクはすべて実行され続けます。すべてのフィルターを 

クリアするには クリア ボタンをクリックします。ダイアログを閉じたときにフィルター

が有効になっている場合は、 ボタンのラベルが太字イタリック体で表示されます。 

 

 

 

 

 

 

 

 

 

 

 

 

：Running task（タスク実行中のアイコン） 

：Follow-up task（フォローアップ・タスクのアイコン） 

：Trying to pause a running task（タスクを一時停止させる際の待ちアイコン） 

：Completed task（タスク完了のアイコン） 

：Cancelled task（キャンセルされたタスクのアイコン） 

：Paused task（一時停止したタスクのアイコン） 

図 4-23 [Filter...] 
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5 補足 

5.1 Mascot Daemon Engineを Windowsのサービスとして動かす方法 
Mascot Daemon のメニューバー[Help]→[Mascot Daemoon Help]→[In Depth] →[Running Daemon as a service]の項をご覧

ください。 

5.2 タスク・データベース 

(1) VistaDB 

VistaDB エンジンは Mascot Daemon に組み込まれていますので、Mascot Daemon をインスト－ルすれば何の設定も必要なく

そのまま利用することができます。他の Database エンジンを使う特別な理由がないようでしたら VistaDB をお使いくださ

い。 

① Task database の作成 

VistaDBの Task database ファイル「taskdb.vd5」は Mascot Daemon をインストールすると次のように自動的に作成さ

れます。 

C:\ProgramData\Matrix Science\Mascot Daemon\taskdb.vdb5 

もし、このファイルが壊れて使えなくなった場合は、次のフォルダに空の taskdb.vd5がありますので、それをコピー

してお使いください。 

C:\ProgramData\Matrix Science\Mascot Daemon\VistaDB 

② Task database の編集 

Task database のテーブル構造は変更することはで

きませんが、テーブルの値は変更することができま

す。たとえば、Mascot Serverを新しい PC に移動した

場合、もし PC のホスト名が変われば Mascot Server

の URL も変わりますので、Mascot Daemon の[Result 

file URL]行に表示されている検索結果 URL リンクは

すべてリンク切れになります。ユーティリティプログ

ラム「C:\Program Files\Matrix Science\Mascot 

Daemon\DBASampleTool.exe」を使って Task database

ファイルの[Mascot_Daemon_Results]テーブルの値に

含まれるホスト名を変更してください。 

1. Mascot Daemon を終了してください。また、タ

スクトレイにある Mascot Daemon Engineも右ク

リックして[Exit]してください。 

2.「taskdb.vd5」ファイルをバックアップしてくだ

さい。 

3.「C:\Program Files\Matrix Science\Mascot 

Daemon\DBASampleTool.exe」をダブルクリックしてください。「VistaDB Table Editor」が起動します。 

4. メニューバー[File]→[Open Database]から「C:\ProgramData\Matrix Science\Mascot Daemon\taskdb.vdb5」を開

いてください。 

5. 左側のイクスプローラーから[Table]→[Mascot_Daemon_Results]→[Data]の順に選択してください。 

6. 右側ウィンドウを右の方にスクロールして[result_url]のカラムを探し、そこに記述されているホスト名を確認し

てください。 

図 4-23 VistaDB Table Editor：ホスト名の確認 

図 4-24 VistaDB Table Editor：ホスト名の変更 
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7. 左側イクスプローラーの[Query]を選択してください。 

8. 右側ウインドウの[Query Expression]入力欄に SQL クエリー実行文を入力してください。たとえば、

「old_server」というホスト名を「new_server」に変更する場合は次の実行文になります。 

     UPDATE Mascot_Daemon_Results SET result_url = 

REPLACE(result_url,'http://old_server','http://new_server'); 

9. [Execute Query]ボタンを押してください。 

10 ホスト名が正しく変更されたことを確認してください。 

11 メニューバー[File]→[Close Database]を選択してください。 

12.「VistaDB Table Editor」を終了してください。 

(2) Access 

Mascot Daemon のメニューバー[Help]→[Mascot Daemoon Help]→[Getting Started] →[Database Engines]→[Access]の

項をご覧ください。 

(3) PostgreSQL 

Mascot Daemon のメニューバー [Help]→ [Mascot Daemoon Help]→ [Getting Started] → [Database Engines]→

[PostgreSQL]の項をご覧ください。 

(4) SQL Server 

Mascot Daemonのメニューバー[Help]→[Mascot Daemoon Help]→[Getting Started] →[Database Engines]→[SQL Server]

の項をご覧ください。 

(5) mySQL 

Mascot Daemon のメニューバー[Help]→[Mascot Daemoon Help]→[Getting Started] →[Database Engines]→[mySQL]の

項をご覧ください。 

(6) Oracle 

Mascot Daemon のメニューバー[Help]→[Mascot Daemoon Help]→[Getting Started] →[Database Engines]→[Oracle]の

項をご覧ください。 

5.3 Stop Massリスト 

PMF 検索の際に、あらかじめ指定した質量が質量データの中に存

在する場合、その値を無視する「Stop Mass 機能」を利用することが

できます。「Stop Mass 機能」を有効にするためには、次のファイル

をひとつ上の階層のMascot Daemonフォルダにコピーしてください。 

C:\ProgramData\Matrix Science\Mascot Daemon\ 

stop_masses\Mascot_Daemon_PMF_stop_masses.txt 

Stop Mass の指定方法は、モノアイソトピック m/z と平均 m/z を

カンマ（ , ）で区切り、一行に記述します。図 5-5 に示す記述例を

ご覧ください。 

 

 

 

 

 

 

 

図 5-5 Stop Mass リスト 
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